Site Creation failing (using Hosting Web Service)

Aug 22, 2007 at 2:29 PM
Hi,

I am using the hosting web service to create a new site with new owner(user). Everything with respect to creating user and ou works ine but fails while trying to create the site.

i am using the method

public void CreateNewSiteNewOwner(string SiteUrl,
string SiteTitle,
string SiteDescription,
string SiteTemplate,
string OwnerFirstName,
string OwnerLastName,
string OwnerLogin,
string OwnerPassword,
string OwnerEmail,
string OUName,
string WebAppUrl,
string ProviderName,
uint nLCID)

which uses the following method to create the SP(WSS) site whete it fails
SPService.hstCreateSite(WebAppUrl, SiteUrl, SiteTitle, SiteDescription, nLCID, SiteTemplate,
siteownerLogin, siteownerName, OwnerEmail, null, null, null, true);

the error i get is: (using try...catch)
object moved to <a href="/_layouts/login.aspx?ReturnURL=%2fService.asmx">here

and the application error in the even viewer is:
The site http://qwe.mycoop6.com could not be created. The following exception occured: Thread was being aborted..

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Any help will be appreciated.


I tested the whole process sucessfully in my development server but i'm facing these hurdles in the production machine. the only difference between the 2 machines is the production server is runnibg 64-bit Windows server 2003 while the development server is not the same.

Thanks,
Regards,
Ramprasad

Aug 23, 2007 at 6:08 PM
an update: the actual error is "user cannot be found"

Thanks
Ramprasad